Degraded Performance in application

Incident Report for Nmbrs Payroll

Resolved

This incident has been resolved.
Posted Sep 01, 2026 - 13:54 CEST

Identified

The issue has been identified and a fix is being implemented.
Posted Sep 01, 2026 - 12:43 CEST

Investigating

We have received a notion of slowness in our application. Customers may experience one or more of the following symptoms:

* Payroll runs may fail to start or complete successfully.
* Pages may load slower than expected.
* General application performance may be reduced.

The issue appears to affect only part of our infrastructure. As a result, not all customers are experiencing problems.

Our technical teams are actively investigating the root cause and working to restore normal performance as quickly as possible.
Posted Sep 01, 2026 - 12:41 CEST
This incident affected: Nmbrs Payroll (Web Application (APM)).