Partial Outage - Nmbrs Recruitment

Incident Report for Nmbrs Payroll

Resolved

This incident has been resolved.
Posted Sep 01, 2026 - 11:09 CEST

Investigating

We are currently experiencing an issue affecting parts of the Nmbrs Recruitment application. We are investigating the root cause of this matter and will update this incident as soon as possible
Posted Sep 01, 2026 - 07:05 CEST
This incident affected: Nmbrs Recruitment (Nmbrs Recruitment).